ত্রুটি "Uncaught TypeError: অনির্ধারিত একটি ফাংশন নয়" এবং এটি কিভাবে ঠিক করবেন

সম্ভবত বেশিরভাগ ব্যবহারকারী তাদের সিএমএসের সর্বশেষ আপডেটের পরে এই ত্রুটিটি দেখতে শুরু করে, বিশেষ করে, তারা ওয়ার্ডপ্রেস jQuery লাইব্রেরী আপডেট করে, যা ওয়েবসাইটগুলিতে বড় সংখ্যক স্ক্রিপ্ট প্রভাবিত করে। উদাহরণস্বরূপ, বিভিন্ন jQuery প্রভাব এবং বৈশিষ্ট্যগুলি ব্যবহার করে স্লাইডার স্ক্রিপ্ট এবং গ্যালারীগুলি ভুলভাবে কাজ শুরু করে। কিছু স্লাইডার স্লিপগুলি ফাঁকা বন্ধ করে দেয় এবং গ্যালারীগুলি ফটোগুলি খুলতে বা তাদের বাড়িয়ে দেওয়ার বন্ধ করে দেয়, তবে এই সমস্ত সমস্যার সমাধান করা যেতে পারে।

JQuery লাইব্রেরি আপডেট করার পরে ঘটেছে এমন সবচেয়ে সাধারণ ত্রুটি একটি ত্রুটি: Uncaught TypeError: অনির্ধারিত কাজ নয়

এই ত্রুটিটি প্রায়শই আপডেট হওয়া ভেরিয়েবল এবং লেখার পরামিতিগুলির সিনট্যাক্সের কারণে ঘটে এবং এটি সম্ভবত আপনার স্ক্রিপ্টগুলিতে লিখিত আছে:

$ (নথি)। প্রস্তুত (ফাংশন () {

এটা এই মত হওয়া উচিত:

jQuery (নথি)। প্রস্তুত (ফাংশন ($) {

উপরের লিখিত কি অনুসারে ত্রুটিগুলি প্রদান করে এবং ত্রুটিগুলি অদৃশ্য হয়ে যায় তার জন্য আপনার স্ক্রিপ্টগুলি সংশোধন করুন, উদাহরণস্বরূপ, স্লাইডারটি আমার জন্য কাজ করে না , পৃষ্ঠাটি বন্ধ করে দেওয়া হয়েছে , সমস্যাটি ঘটেছে কারণ সিএমএস ওয়ার্ডপ্রেসটি jQuery লাইব্রেরির একটি আপডেট সংস্করণ ব্যবহার করে এবং টেমপ্লেটে স্ক্রিপ্টগুলি লিখিত হয়েছিল পুরোনো সংস্করণের জন্য, উপরের বর্ণিত স্ক্রিপ্টগুলি ঠিক করার জন্য এটি যথেষ্ট ছিল এবং সমস্যাটি অদৃশ্য হয়ে গিয়েছিল।

উপরের লিখিত কি অনুসারে ত্রুটিগুলি প্রদান করে এবং ত্রুটিগুলি অদৃশ্য হয়ে যায় তার জন্য আপনার স্ক্রিপ্টগুলি সংশোধন করুন, উদাহরণস্বরূপ, স্লাইডারটি আমার জন্য কাজ করে না , পৃষ্ঠাটি বন্ধ করে দেওয়া হয়েছে , সমস্যাটি ঘটেছে কারণ সিএমএস ওয়ার্ডপ্রেসটি jQuery লাইব্রেরির একটি আপডেট সংস্করণ ব্যবহার করে এবং টেমপ্লেটে স্ক্রিপ্টগুলি লিখিত হয়েছিল পুরোনো সংস্করণের জন্য, উপরের বর্ণিত স্ক্রিপ্টগুলি ঠিক করার জন্য এটি যথেষ্ট ছিল এবং সমস্যাটি অদৃশ্য হয়ে গিয়েছিল।

আপনার প্রতিক্রিয়া ছেড়ে দিন বা মন্তব্যগুলিতে আপনার প্রশ্ন লিখুন, যদি আপনার কোন অসুবিধা হয় তবে আমরা সাহায্য করার চেষ্টা করব।

(6 বার 6 বার দেখা হয়েছে, আজ 1 টি মতামত)